
GC-Prevue Instructions

Welcome to GC-Prevue. These instructions include two sections: THE
GC-PREVUE INTERFACE and LOADING DATA. They are written for Version
9 and are designed to be used in conjunction with the Online Help
available in Prevue. 

The GC-Prevue Interface
Starting GC-Prevue
To start GC-Prevue:

1.   Double-click the program icon on your desktop,
-or-

2.  Go to Start, Programs, GC-Prevue.

For this and other examples, you will open a data set that has been
provided for you. GC-Prevue saves jobs in a special format with a file
extension of .gwk. The .gwk includes the Gerber layers, all newly
generated layers, aperture lists, drill racks, function settings and many
other attributes associated with the work in progress.

Exercise 1.1: Opening a .gwk File

To open the file:

1.  On the File menu, click Open.

2.  In the Look in field, navigate to GC-Prevue and select Examples.



3.  From the Examples folder, select the Loaded.gwk file and click Open.
The data set will load into your Graphical Viewer and you should see
the following display:

4.  Leave this .gwk file open.

Main Screen Components
There are four main components of the user interface:

•  Graphical Viewer

•  Navigation View

•  Coordinates Display

•  GC Explorer

Graphical Viewer

GC-Prevue features a Windows-based graphical work environment. The
main window is the Graphical Viewer.



Figure 1.1: The Graphical Viewer
The Graphical Viewer presents the board image by displaying the board
layers. When GC-Prevue first opens on your screen, the Graphical Viewer
is very small. (See Exercise 1.1.) It is a separate window and can be moved
and re-sized like any other window.

Exercise 1.2: Moving and Sizing Windows

1. Click anywhere on the title bar of the Graphical Viewer  to move the
window around the screen.

2. Click the bottom right corner of the Graphical Viewer with your
mouse and drag downward to expand the window.

✎  The opening size of the Graphical Viewer window is a default setting that can be
changed. To change the setting:

From the Tools menu, select Customize.
From the Edit tab, check Initially maximize graphical views.



Navigation View

Figure 1.2: The Navigation View Window
This window depicts the board data in relationship to the bed size. It
tracks the position of the board graphically and also gives you another
way to move the board data about onscreen.

To see how this works, position the cursor over the rectangle that
represents the bed extents and click and drag it to move around the board
data.  You can also click within Navigation View to jump from point to
point and right-click to activate a drop-down menu of zoom options.

Exercise 1.3: Opening the Navigation View Window

1. Click the top 2 gray lines of the window (the “Grabber Bar”, which
turns into the Title Bar once the window is opened.)

2. Drag to move the window out onto the screen; a title bar appears and
the window can be resized and moved about.

3. Drag the window back to the left side of your screen.

Coordinates Display

The Coordinates Display tracks the position of the cursor by X, Y
coordinates relative to user-set, absolute and relative positions on the
board.  It also shows any data that has been selected.



Figure 1.3: The Coordinates Display Window
User X,Y: While GC-Prevue maintains all data in terms of its internal
absolute coordinate system, it may be useful for you to work in a
coordinate system offset from the absolute system.  To set the User
Coordinate system origin to the current crosshair position, Press Alt Z
(also available from the Tools menu.)

Absolute X,Y: This gives the current crosshair position in the program’s
internal coordinates system.

Relative X,Y: This gives the current data cursor position in coordinates
relative to the last position the Relative display was "zeroed" (reset to zero
using the Z key).  Also, GC-Prevue shows the linear Distance between the
current and last-zero cursor positions.  These values are useful for
measuring and precise shifting.

Exercise 1.4: Opening and Closing the Coordinates Display Window

Another way to open and close windows is to double-click the Grabber
Bar. To do this:

1. Double-click the Grabber Bar of the Coordinates Display window. It
opens up with a title bar on your screen.

2. Double-click the title bar to send the window back to the left side of
your screen.



GC Explorer

Figure 1.4: The GC Explorer Window
In this window, you can configure and edit data files. Notice that it has a
"tree structure", which means that you can expand and contract the layers
via the (+) and (-) signs. When you click the (+) sign next to a layer, it
expands to show the data layer(s) associated with that physical layer. You
can also right-click a layer to open a menu to change the layer’s view and
edit status and to open the Property page for that layer.

Exercise1.5: Opening a Property Page in GC Explorer

1. Double-click the Grabber Bar to open GC Explorer.

2. Click the (+) sign next to the Top Signal layer (P3) to expand the layer
list. Double-click the Top Signal layer to open the information panel
(properties) on the right side.

3. The Property page shows layer attributes which can be edited. Name
the layer "1", set the type to Signal and change the trace color by
clicking the arrow next to the color and selecting a different color.



4. Click OK in the lower left corner of the dialog box. GC Explorer will
automatically close.

✎  Clicking the close button  in the upper-right corner of GC Explorer closes the
window without saving your changes. To restore GC Explorer, go to View on the
Menu bar, select Toolbars, and select GC Explorer.

Exercise 1.6: Setting a Layer’s Edit Status in GC Explorer

1. In GC Explorer, right-click on the drill drawing layer to display an
option menu.

2. Select Hide from the choices. The layer will still be visible in the
Graphical Viewer.

3. Click anywhere in the  Graphical Viewer and the screen will be
redrawn and the drill drawing layer will no longer be visible.

✎  If you have made changes that are not visible on your screen, try using the Redraw
function. This is accomplished by either pressing D on your keyboard or select
Redraw Current Window from the View menu.

Multiple Windows
You can create multiple windows on your screen that can be sized and
moved about the screen to enhance working efficiency. Each window can
also be viewed from the bottom side of the board. If multiple graphics



windows are open, the crosshair automatically updates in the other
windows, showing either a top or a bottom view.

To create a new window, select Window from the menu bar and select
New Window.

You can also create a new window by using the left mouse button to draw
a window in the Graphical Viewer. When you release the left mouse
button, a menu appears containing several zoom and edit options. Select
Zoom to Window to create a new window.

Once you have created several windows, you can move them around the
screen and stretch them to convenient sizes.  You can also maneuver them
using the options under the Window menu.

Exercise 1.7: Creating Multiple Views of Board Data

1. Select Window from the Menu bar and select New Window. A new
window, Loaded.gwk:2, will open.

2. To arrange the windows, select Window from the Menu bar and select
Tile Vertically.

3. The windows will be arranged side by side. You can now change the
view of the second window to a bottom-side view. Click the GC icon in
the upper left corner to activate a drop-down menu. From this menu,
select Bottom Side View.



4. The window now displays the data set viewed from the bottom. Notice
that the GC icon in the left-corner of the window is now reversed.

✎  When you have multiple windows open, the crosshair automatically updates in the
other windows. Any editing function performed on one window, such as selecting
data, will be displayed in all windows.

Toolbars
Toolbars are groupings of buttons that give you easy access to features.
You can customize toolbars by adding or removing buttons, and you can
move toolbars to any position on the graphical screen.

To open a toolbar, double-click on the left margin; it will open in place.
Double-clicking again will restore the tool bar.

✎  If you close the toolbar by clicking on the close button   it will no longer be visible.
To bring the toolbar back to your screen, go to the View menu, select Toolbars, and
check next to the one you want to view.

To move toolbars, position the cursor over the toolbar's margin, press the
left-mouse button, and drag to the new position.  A title appears on the
toolbar giving the feature category.
✎  Every command available from a toolbar is also available from a drop-down menu.

Exercise 1.8: Moving Toolbars

A title bar will identify each toolbar once it is moved onto the Graphical
Viewer. To do this:



1. Click the left mouse button on the toolbar Grabber, the double gray
line at the left end of the toolbar.

2. Drag the toolbar onto the Graphical Viewer and release the mouse
button.

3. The Toolbar is now identified as the Layers toolbar and can be moved
by simply dragging the Title bar.

Exercise 1.9:  Customizing Toolbars

Toolbars can be customized and new ones created. In this exercise, you
will add a command to an existing toolbar.

1. From the Tools menu, select Customize.
2. Select the Commands tab.



3. With the File category selected, left-click on the icon for Import, ,
drag to the File toolbar, and release the mouse.

4. The Import icon is now on the toolbar.

Loading Data
The process of loading data files is designed to be as easy as possible.  If
your files are in the form of data files such as Gerber, aperture and drill
tables, drill and rout files and so on, the Import feature will handle them
automatically. Existing GraphiCode files (.gwk) are opened from the File
menu using Open.  (See Exercise 1.1 in previous section.) There is also a
Most Recently Used list at the end of the File menu to allow for the rapid
selection of recently used files.

Importing Files
The following is an example of importing files using
GC-Prevue’s automatic file recognition, in which all the file types are
recognized. Following this example, there is an exercise using Tool Table
Assistant to import files that are not automatically recognized.

1. From the File menu, select Import. The Import dialog box is displayed.



2. In the Files of Type list, select a File Type from the drop-down list. In
this example, All Files, (the default choice), is selected.

3. Select the data files for your job and click Import.

4. The File Type Confirmation dialog box appears. If the file type has
been automatically recognized, there will be a green check mark in the
Import column. (If the file type has not been recognized, the mark will be a
red X and the file type will be unknown. This can be corrected using Tool
Table Assistant, explained below.) Check the accuracy of the information;
you can edit the data by right-clicking in the Format field and choosing
the View/Edit File option. You can change the file type by selecting a
different one from the drop-down list and you can also set the
parameters for the type of data by double-clicking the Format field.

Figure 2.1: File Type Confirmation

✎  When you double-click the Format field of a drill table or aperture table file, you open
up the first dialog box of the Tool Table Assistant. This is a step-by-step process to
help you set the correct file parameters and is explained more fully below. In addition,
see Online Help for more information.

5. Click OK.  The Tool Table Assignment dialog box appears. Here the
drill and aperture lists are matched to each layer.  To change the tool
list, left click in the Tool List field, and select one of the available tool
lists. Click OK.  If the data does not contain tool table information, you
will be asked if you wish to add default apertures to the table.  Select
Yes to All.



Figure 2.2: Tool Table Assignment

The files are now loaded and the File Import Results dialog box appears.
By selecting OK, the files will be imported into the Graphical Viewer. The
Import Results process is explained more fully later in this section.

Selecting Save As from the File menu will allow you to name and save the
file. In this example, it is not necessary to save the file.

Tool Table Assistant

At times, you will need to load data files that contain aperture or drill
tables in formats that are not recognized.  When this occurs, GC-Prevue
provides a utility, Tool Table Assistant, that allows you to specify the
unfamiliar format, load it, and recognize this format in the future.

In this exercise, you’ll use Tool Table Assistant.

Exercise 2.1: Using Tool Table Assistant

1. From the File menu, select Import.
2. In the Look in list, navigate to GC-Prevue and select the Examples

folder.
3. Select the following files by holding down the Control key while you

select each file: Aperture.rep, drill.gbr, Ncdrill.rep, Ncdrill.drl, Layer1.gbr
through Layer 6.gbr, Silkbot.gbr, Silktop.gbr, Smaskbot.gbr and
Smasktop.gbr. Click Import.

4. Review the File Type Confirmation dialog box.



Figure 2.3: File Type Confirmation
5. Note that the Ncdrill.rep file is recognized as an Ncdrill.drl file. Click in

the File Type field to open the drop-down menu of file types; select
Drill Rack. GC-Prevue  recognizes that file format and automatically
opens Tool Table Assistant, Format Setup.

Figure 2.4: Format Setup
You can now set the parameters of the drill file.

6. In Format Setup, confirm that the Drill Table option of File Type is
selected. Set the Original data type, which is how the data is
formatted, to Delimited.



7. Enter the numbers of the first and last rows that contain only data.  In
this example, the first line of data is row 7 and the last is row 11.

8. Click Next and the Tool File Layout dialog box is displayed. Select
Space as the delimiter. (This is a toggle; you can unselect Space to
revert back.)

Figure 2.5: Tool File Layout

NOTE: For Delimited files, you must choose the type of delimiter.  In the
above file, this is by Space.  If the delimiter that separates the columns is
not included in one of the options, click Other and enter the delimiter.
Multiple delimiters need to be separated by a comma.

9. Fill in the Drill Rack Information and Plating Information fields.
(Note the column headings above the fields.) Click Next.

10. The Results dialog box is displayed, as shown here:



Figure 2.6: Results
This shows the original (raw ASCII) file and the newly converted file.
✎  If you want GC-PREVUE to recognize this type of tool table in the future, you can

select Memorize. See Online Help for more information.
11. Click Finish. You’ll be asked if you want to save the tool list

changes; select Yes if you wish to save the file.

The Tool Table Assistant loads the drill file and displays the File Type
Confirmation dialog box again, this time showing that the drill file has
been successfully imported.



Figure 2.7: File Type Confirmation

12. Click OK. The Tool Table Assignment dialog box is displayed.

Figure 2.8: Tool Table Assignment
13. The Tool Table Assignment assigns an aperture table to each of the

data layers.  If the data does not contain an embedded aperture table,
you will be asked if you wish to add default apertures to each table.
Click OK.

The File Import Results dialog box is now displayed. This is a process
that allows you to look at each layer individually, set attributes and edit
layer characteristics. Exercise 2.2 will continue with the Importing process.



File Import Results
The File Imports Results dialog box appears after you have clicked OK in
the Tool Table Assignment dialog box.  It consists of three data tabs that
present a variety of information about each data layer.

Figure 2.9: File Import Results

File Tab:
Double-paned property page, the right side of which allows you to
name the layer, set layer type, and change the colors of pads and
traces. The left side offers tools to let you pan and zoom on the
board in the Graphical Viewer.

Errors Tab:
Lists any problems with any of the layer features.  For example, any
missing apertures will be listed in this window.

Tools Tab:
Opens either a version of Drill Table or an Aperture Table Editor
for that layer.

You can set information for each layer that has been imported by filling in
the information for each layer and selecting the Next File button in the
lower-left corner. If you select OK instead of Next File, the Import Results
dialog box will close and the layers will be loaded without your specific
settings.



✎  You can double-click on a layer in GC Explorer. That opens the property page for
that layer and you can enter information there.

Exercise 2.2:  File Import Results

This shows the top silkscreen layer.

1. Name the layer Silkscreen top, keeping in mind that this is an
optional step but can make it easier to use GC Explorer.

2. Pick the layer type Silkscreen from the drop-down list.

3. Zoom in on the layer by using the Pan and Zoom controls.  Try
experimenting with both controls.

4. The colors of pads and traces can be changed here. Change the color
by clicking the drop down arrow and selecting a new color.

✎  The color change is not immediately visible to you. Click on the Next File button and
then come back by using the Previous button; the board’s colors will now be those
you selected.

5. For this layer, select Top from the Side choices.

Repeat these steps for each layer. After the information on the last layer
has been entered, select OK. The board is now loaded and will look
similar to this:



6. Save your file. On the File menu, select Save and the Save As dialog
box is displayed. Make sure the Examples folder is the default, and in
the File Name field, name your file Practice.gwk; click Save.
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